Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/python-setuptools/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
index 0dff2768..3b048d6c 100644
--- a/extra/python-setuptools/PKGBUILD
+++ b/extra/python-setuptools/PKGBUILD
@@ -28,7 +28,13 @@ eval "$(
declare -f package | \
sed -r 's/cd setuptools;?$/cd setuptools-$pkgver/'
)"
+eval "$(
+ declare -f check | \
+ sed -r 's/cd setuptools;?$/cd setuptools-$pkgver/'
+)"
-# Don't bother with the tests.
-unset check
-unset checkdepends
+# Skip the last patch as it doesn't apply
+eval "$(
+ declare -f prepare | \
+ sed '/add-dependency.patch/d'
+)"