Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-05-05 04:54:33 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-05-05 04:54:33 +0300
commit2e81edefebeb1bd74298b2c7f78a4cf060cc65f8 (patch)
tree9d331400e0f044761097ac98dba376b2dfa16cab
parent200a90548a1dd72772194d31ebd64b61ee4a4899 (diff)
extra/python-setuptools: Restore tests and disable one patchHEADmaster
-rw-r--r--extra/python-setuptools/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
index 0dff2768..3b048d6c 100644
--- a/extra/python-setuptools/PKGBUILD
+++ b/extra/python-setuptools/PKGBUILD
@@ -28,7 +28,13 @@ eval "$(
declare -f package | \
sed -r 's/cd setuptools;?$/cd setuptools-$pkgver/'
)"
+eval "$(
+ declare -f check | \
+ sed -r 's/cd setuptools;?$/cd setuptools-$pkgver/'
+)"
-# Don't bother with the tests.
-unset check
-unset checkdepends
+# Skip the last patch as it doesn't apply
+eval "$(
+ declare -f prepare | \
+ sed '/add-dependency.patch/d'
+)"