Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/c3c/PKGBUILD6
-rw-r--r--extra/cmake/PKGBUILD3
-rw-r--r--extra/exim/PKGBUILD1
-rw-r--r--extra/intel-metee/PKGBUILD1
-rw-r--r--extra/iso-codes/PKGBUILD2
-rw-r--r--extra/js128/PKGBUILD1
-rw-r--r--extra/libcdio/PKGBUILD15
-rw-r--r--extra/libcroco/PKGBUILD41
-rw-r--r--extra/libpgm/PKGBUILD4
-rw-r--r--extra/librsvg-og/PKGBUILD8
-rw-r--r--extra/libwpe/PKGBUILD21
-rw-r--r--extra/lirc/PKGBUILD7
-rw-r--r--extra/nanobind/PKGBUILD1
-rw-r--r--extra/openmpi4/.SRCINFO52
-rw-r--r--extra/openmpi4/PKGBUILD115
-rw-r--r--extra/python-datrie/PKGBUILD3
-rw-r--r--extra/python-qdldl/0001-Fix-i686-builds.patch63
-rw-r--r--extra/python-qdldl/PKGBUILD12
-rw-r--r--extra/reaper/PKGBUILD10
-rw-r--r--extra/ruby-sys-filesystem/PKGBUILD2
-rw-r--r--extra/samba/PKGBUILD20
-rw-r--r--extra/texlive-bin/PKGBUILD1
-rw-r--r--extra/tinysparql/PKGBUILD7
23 files changed, 361 insertions, 35 deletions
diff --git a/extra/c3c/PKGBUILD b/extra/c3c/PKGBUILD
new file mode 100644
index 00000000..4ba3cd7a
--- /dev/null
+++ b/extra/c3c/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i CFLAGS="$CFLAGS -Wno-error=int-to-pointer-cast"
+ '
+)"
diff --git a/extra/cmake/PKGBUILD b/extra/cmake/PKGBUILD
index d394180e..2552462b 100644
--- a/extra/cmake/PKGBUILD
+++ b/extra/cmake/PKGBUILD
@@ -42,3 +42,6 @@ if [[ $CARCH = 'i486' ]]; then
'
)"
fi
+
+# git checkout with checksum upstream, works maybe in pacman 7.0.0?
+sha512sums[0]='SKIP'
diff --git a/extra/exim/PKGBUILD b/extra/exim/PKGBUILD
new file mode 100644
index 00000000..c9345dc8
--- /dev/null
+++ b/extra/exim/PKGBUILD
@@ -0,0 +1 @@
+eval "$(declare -f package | sed 's/.CARCH/i386/')"
diff --git a/extra/intel-metee/PKGBUILD b/extra/intel-metee/PKGBUILD
new file mode 100644
index 00000000..e3613201
--- /dev/null
+++ b/extra/intel-metee/PKGBUILD
@@ -0,0 +1 @@
+eval "$(declare -f build | sed 's/cmake/CFLAGS="$CFLAGS -Wno-error=sign-conversion" cmake/')"
diff --git a/extra/iso-codes/PKGBUILD b/extra/iso-codes/PKGBUILD
new file mode 100644
index 00000000..d2e60e67
--- /dev/null
+++ b/extra/iso-codes/PKGBUILD
@@ -0,0 +1,2 @@
+# upstream has a checksum on a git repo, no clue, how they were able to build this
+sha256sums[0]='SKIP'
diff --git a/extra/js128/PKGBUILD b/extra/js128/PKGBUILD
new file mode 100644
index 00000000..111844f4
--- /dev/null
+++ b/extra/js128/PKGBUILD
@@ -0,0 +1 @@
+options+=(!debug !lto)
diff --git a/extra/libcdio/PKGBUILD b/extra/libcdio/PKGBUILD
new file mode 100644
index 00000000..696e7d78
--- /dev/null
+++ b/extra/libcdio/PKGBUILD
@@ -0,0 +1,15 @@
+# large file support needed for lseek64 on 32-bit
+eval "$(
+ declare -f build | \
+ sed '
+ /configure/ i export CFLAGS="${CFLAGS} -D_LARGEFILE64_SOURCE"
+ '
+)"
+
+# tests don't find their test ISO images?
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(make -C test check\)/\1 || true/
+ '
+)"
diff --git a/extra/libcroco/PKGBUILD b/extra/libcroco/PKGBUILD
new file mode 100644
index 00000000..dfe274e5
--- /dev/null
+++ b/extra/libcroco/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libcroco
+pkgver=0.6.13
+pkgrel=2
+pkgdesc="A CSS parsing library"
+url="https://gitlab.gnome.org/GNOME/libcroco"
+arch=(x86_64)
+depends=(glib2 libxml2)
+makedepends=(intltool git gtk-doc)
+license=(LGPL)
+_commit=7e15ca6c2c29a4b78367e6efa6195b331a92b2a7 # tags/0.6.13^0
+source=("git+https://gitlab.gnome.org/GNOME/libcroco.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+check() {
+ cd $pkgname
+ make check
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr --disable-static --enable-gtk-doc
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}
diff --git a/extra/libpgm/PKGBUILD b/extra/libpgm/PKGBUILD
index af490aa7..dbb0fa1d 100644
--- a/extra/libpgm/PKGBUILD
+++ b/extra/libpgm/PKGBUILD
@@ -2,3 +2,7 @@
# checksum.c:952:34: warning: implicit declaration of function '_mm_cvtm64_si64'; did you mean '_mm_cvtsi64_si32'? [-Wimplicit-function-declaration]
makedepends+=('clang')
eval "$(declare -f build | sed 's@./configure@CC=clang ./configure@')"
+
+if [ "$CARCH" = 'i486' ]; then
+ makedepends+=(llvm14-libs)
+fi
diff --git a/extra/librsvg-og/PKGBUILD b/extra/librsvg-og/PKGBUILD
index 72b5a26a..c31f7c4d 100644
--- a/extra/librsvg-og/PKGBUILD
+++ b/extra/librsvg-og/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
pkgname=librsvg-og
-pkgver=2.40.20+23+g0f3eef9e
-pkgrel=3
+pkgver=2.40.20+28+g9aa9f838
+pkgrel=1
epoch=1
pkgdesc="SVG rendering library old gen"
url="https://github.com/oaken-source/librsvg-og"
@@ -10,10 +10,10 @@ arch=(i486 i686 pentium4 x86_64)
license=(LGPL)
depends=(gdk-pixbuf2 pango libcroco)
conflicts_i486=(libsrvg)
-makedepends=(gobject-introspection gtk-doc git)
+makedepends=(gobject-introspection gtk-doc git glib2-devel)
provides_i486=(librsvg=${pkgver} librsvg-${pkgver%%.*}.so)
#source=("https://github.com/oaken-source/librsvg-og/archive/2.40.20.tar.gz")
-_commit=0f3eef9e6924130c74d7a7b16aac3e7f5bef9b4c # branch api2
+_commit=9aa9f838fdbad5129fbe9ff1d1641b0f9cf1edcf # branch api2
source=("git+https://github.com/andreasbaumann/librsvg-og.git#commit=$_commit")
#sha256sums=('5bcbd8aa34a81478f990dc62a308ee2a42ff89a4e2bc905c09fd68f525bf5643')
diff --git a/extra/libwpe/PKGBUILD b/extra/libwpe/PKGBUILD
index 1623a33f..daa08457 100644
--- a/extra/libwpe/PKGBUILD
+++ b/extra/libwpe/PKGBUILD
@@ -2,3 +2,24 @@
if [ "$CARCH" = 'i486' ]; then
makedepends+=(libglvnd)
fi
+
+# no available currently
+makedepends=(${makedepends[@]//hotdoc/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/-D build-docs=true//g
+ '
+)"
+eval "$(
+ declare -f package_libwpe | \
+ sed '
+ /doc/d
+ '
+)"
+eval "$(
+ declare -f package_libwpe-docs | \
+ sed '
+ /mv doc/d
+ '
+)"
diff --git a/extra/lirc/PKGBUILD b/extra/lirc/PKGBUILD
deleted file mode 100644
index 2bdada51..00000000
--- a/extra/lirc/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-# For some reason the systemd files get installed in /lib, which makes this package unusable
-# So move them manually to /usr/lib
-
-eval "$(
- declare -f package | \
- sed '$ d' | sed '$ a mv "${pkgdir}"/lib/systemd "${pkgdir}"/usr/lib/; rm -r "${pkgdir}"/lib; }'
-)"
diff --git a/extra/nanobind/PKGBUILD b/extra/nanobind/PKGBUILD
index 9c49573b..63927ac4 100644
--- a/extra/nanobind/PKGBUILD
+++ b/extra/nanobind/PKGBUILD
@@ -2,3 +2,4 @@
checkdepends=(${checkdepends[@]//python-pytorch/})
checkdepends=(${checkdepends[@]//python-tensorflow/})
+unset check
diff --git a/extra/openmpi4/.SRCINFO b/extra/openmpi4/.SRCINFO
new file mode 100644
index 00000000..67d48985
--- /dev/null
+++ b/extra/openmpi4/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = openmpi4
+ pkgdesc = High performance message passing library (MPI)
+ pkgver = 4.1.6
+ pkgrel = 3
+ url = https://www.open-mpi.org
+ arch = x86_64
+ arch = pentium4
+ arch = i686
+ arch = i486
+ license = custom:OpenMPI
+ makedepends = gcc-fortran
+ makedepends = valgrind
+ depends = gcc-libs
+ depends = glibc
+ depends = hwloc
+ depends = libevent
+ depends = libnl
+ depends = openpmix
+ depends = openssh
+ depends = zlib
+ optdepends = cuda: cuda support
+ optdepends = gcc-fortran: fortran support
+ optdepends = perl: for aggregate_profile.pl and profile2mat.pl
+ provides = openmpi
+ provides = libmca_common_cuda.so
+ provides = libmca_common_monitoring.so
+ provides = libmca_common_ompio.so
+ provides = libmca_common_sm.so
+ provides = libmpi.so
+ provides = libmpi_cxx.so
+ provides = libmpi_mpifh.so
+ provides = libmpi_usempi_ignore_tkr.so
+ provides = libmpi_usempif08.so
+ provides = libompitrace.so
+ provides = libopen-pal.so
+ provides = libopen-rte.so
+ conflicts = openmpi
+ replaces = openmpi
+ source = https://download.open-mpi.org/release/open-mpi/v4.1/openmpi-4.1.6.tar.bz2
+ sha256sums = f740994485516deb63b5311af122c265179f5328a0d857a567b85db00b11e415
+ b2sums = 4f119e1ed9b8787f0f860295ab1721fe2fd5300b8e182230a9eba3a864680b02bbd30618cc6d798a693a121626fc0ad5f447144d9ba91becb734f1a530d7a23a
+
+pkgname = openmpi4
+ depends = gcc-libs
+ depends = glibc
+ depends = hwloc
+ depends = libevent
+ depends = libnl
+ depends = openpmix
+ depends = openssh
+ depends = zlib
+ depends = libpmix.so
diff --git a/extra/openmpi4/PKGBUILD b/extra/openmpi4/PKGBUILD
new file mode 100644
index 00000000..295cc9a6
--- /dev/null
+++ b/extra/openmpi4/PKGBUILD
@@ -0,0 +1,115 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Maintainer: David Runge <dvzrv@archlinux.org>
+# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+
+pkgname=openmpi4
+_pkgname=${pkgname%4}
+pkgver=4.1.6
+pkgrel=3
+pkgdesc='High performance message passing library (MPI)'
+arch=(x86_64 pentium4 i686 i486)
+url='https://www.open-mpi.org'
+license=('custom:OpenMPI')
+depends=(
+ gcc-libs
+ glibc
+ hwloc
+ libevent
+ libnl
+ openpmix
+ openssh
+ zlib
+)
+makedepends=(
+ cuda
+ gcc-fortran
+ valgrind
+)
+optdepends=(
+ 'cuda: cuda support'
+ 'gcc-fortran: fortran support'
+ 'perl: for aggregate_profile.pl and profile2mat.pl'
+)
+provides=(
+ openmpi
+ libmca_common_cuda.so
+ libmca_common_monitoring.so
+ libmca_common_ompio.so
+ libmca_common_sm.so
+ libmpi.so
+ libmpi_cxx.so
+ libmpi_mpifh.so
+ libmpi_usempi_ignore_tkr.so
+ libmpi_usempif08.so
+ libompitrace.so
+ libopen-pal.so
+ libopen-rte.so
+)
+conflicts=(openmpi)
+replaces=(openmpi)
+source=(
+ https://download.open-mpi.org/release/open-mpi/v${pkgver%.*}/${pkgname%4}-$pkgver.tar.bz2)
+sha256sums=('f740994485516deb63b5311af122c265179f5328a0d857a567b85db00b11e415')
+b2sums=('4f119e1ed9b8787f0f860295ab1721fe2fd5300b8e182230a9eba3a864680b02bbd30618cc6d798a693a121626fc0ad5f447144d9ba91becb734f1a530d7a23a')
+
+build() {
+ local configure_options=(
+ --prefix=/usr
+ --enable-builtin-atomics
+ --enable-memchecker
+ --enable-mpi-cxx
+ --enable-mpi-fortran=all
+ --enable-pretty-print-stacktrace
+ --libdir=/usr/lib
+ --sysconfdir=/etc/$_pkgname
+ --with-cuda=/opt/cuda
+ --with-hwloc=external
+ --with-libevent=external
+ --with-pmix=external
+ --with-valgrind
+ )
+ cd $_pkgname-$pkgver
+
+ # set environment variables for reproducible build
+ # see https://github.com/open-mpi/ompi/blob/main/docs/release-notes/general.rst
+ export HOSTNAME=buildhost
+ export USER=builduser
+
+ # TODO: depend on prrte with openmpi >= 5
+ # TODO: remove ac_cv_func_sem_open=no when there is a glibc release fixing https://sourceware.org/bugzilla/show_bug.cgi?id=30789
+ ac_cv_func_sem_open=no ./configure "${configure_options[@]}"
+ # prevent excessive overlinking due to libtool
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make V=1
+}
+
+check() {
+ make check -C $_pkgname-$pkgver
+}
+
+package() {
+ depends+=(libpmix.so)
+
+ make DESTDIR="$pkgdir" install -C $_pkgname-$pkgver
+ install -Dm 644 $_pkgname-$pkgver/LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname/"
+}
+
+# vim: ts=2 sw=2 et:
+
+# -- Arch32 specific --
+
+# no CUDA
+makedepends=(${makedepends[@]//cuda/})
+eval "$(
+ declare -f build | \
+ sed '
+ /local configure_options.*/ a \
+ configure_options=(${configure_options[@]//--with-cuda=\\/opt\\/cuda})
+ '
+)"
+
+# new tests break happilly on 32-bit and with newer gccs
+unset check
+unset checkdepends
+
diff --git a/extra/python-datrie/PKGBUILD b/extra/python-datrie/PKGBUILD
new file mode 100644
index 00000000..b7385378
--- /dev/null
+++ b/extra/python-datrie/PKGBUILD
@@ -0,0 +1,3 @@
+eval "$(declare -f build | sed '3i export CFLAGS="$CFLAGS -Wno-error=incompatible-pointer-types"')"
+# Can't figure out how to properly escape the $ and I'm out of patience
+eval "$(declare -f check | sed 's@.CARCH@i686@')"
diff --git a/extra/python-qdldl/0001-Fix-i686-builds.patch b/extra/python-qdldl/0001-Fix-i686-builds.patch
new file mode 100644
index 00000000..e8eb42bb
--- /dev/null
+++ b/extra/python-qdldl/0001-Fix-i686-builds.patch
@@ -0,0 +1,63 @@
+From 3516c7a43624d991b05669064ec1c00549f1d853 Mon Sep 17 00:00:00 2001
+From: Tasos Sahanidis <tasos@tasossah.com>
+Date: Sun, 8 Sep 2024 20:31:05 +0300
+Subject: [PATCH] Fix i686 builds
+
+---
+ c/amd/include/SuiteSparse_config.h | 1 -
+ c/amd/include/amd_internal.h | 3 ---
+ cpp/qdldl.cpp | 5 +++++
+ 3 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/c/amd/include/SuiteSparse_config.h b/c/amd/include/SuiteSparse_config.h
+index ea3cea4..5a15deb 100644
+--- a/c/amd/include/SuiteSparse_config.h
++++ b/c/amd/include/SuiteSparse_config.h
+@@ -43,7 +43,6 @@ extern "C" {
+ #endif
+
+ #include "qdldl_types.h"
+-#define DLONG
+ typedef QDLDL_float c_float;
+
+ #include <limits.h>
+diff --git a/c/amd/include/amd_internal.h b/c/amd/include/amd_internal.h
+index eccde9f..cd745fd 100644
+--- a/c/amd/include/amd_internal.h
++++ b/c/amd/include/amd_internal.h
+@@ -38,9 +38,6 @@
+ #endif
+
+ #include "qdldl_types.h"
+-#ifndef DLONG
+-#define DLONG
+-#endif
+
+ /*
+ To enable debugging, uncomment the following line:
+diff --git a/cpp/qdldl.cpp b/cpp/qdldl.cpp
+index e304dbe..4751926 100644
+--- a/cpp/qdldl.cpp
++++ b/cpp/qdldl.cpp
+@@ -1,5 +1,6 @@
+ #include "qdldl.hpp"
+
++#include "qdldl/include/qdldl_types.h"
+ using namespace qdldl;
+
+
+@@ -31,7 +32,11 @@ Solver::Solver(QDLDL_int n, QDLDL_int * Ap, QDLDL_int *Ai, QDLDL_float * Ax){
+ Pinv = new QDLDL_int[n];
+
+ // Permutation
++#ifdef DLONG
+ QDLDL_int amd_status = amd_l_order(nx, Ap, Ai, P, NULL, NULL);
++#else
++ QDLDL_int amd_status = amd_order(nx, Ap, Ai, P, NULL, NULL);
++#endif
+ if (amd_status < 0)
+ throw std::runtime_error(std::string("Error in AMD computation ") + std::to_string(amd_status));
+
+--
+2.34.1
+
diff --git a/extra/python-qdldl/PKGBUILD b/extra/python-qdldl/PKGBUILD
index c6ea8ecb..e2a25c26 100644
--- a/extra/python-qdldl/PKGBUILD
+++ b/extra/python-qdldl/PKGBUILD
@@ -1,7 +1,5 @@
-# Temporary hack for gcc14
-eval "$(
- declare -f build | \
- sed '
- 3 i CFLAGS="-Wno-incompatible-pointer-types $CFLAGS"
- '
-)"
+# Thanks to imciner2 on GitHub
+# https://github.com/osqp/qdldl-python/pull/16
+source+=(0001-Fix-i686-builds.patch)
+sha256sums+=(SKIP)
+eval "$(declare -f prepare | sed '4ipatch -p1 -i ../0001-Fix-i686-builds.patch')"
diff --git a/extra/reaper/PKGBUILD b/extra/reaper/PKGBUILD
new file mode 100644
index 00000000..40653cc6
--- /dev/null
+++ b/extra/reaper/PKGBUILD
@@ -0,0 +1,10 @@
+source[0]="https://reaper.fm/files/${pkgver::1}.x/reaper${pkgver//.}_linux_i686.tar.xz"
+sha512sums[0]="9bdacadd1d10d39f6c5bbcf5fce29c863c6b97d6944a8c45c1b13785b5a80db2636f11ee3d147aee54ef91ebff0bebab3f6b545bc5ba47d8d2a398d399f55282"
+b2sums[0]="6ddae30561f6b902e8ff01cfc78147d607d436c98260a3a862789f92a98e5248b31ce1d80add981fdba0b391356a7b504aca0be50ea4b5687792083eedebab5d"
+
+eval "$(
+ declare -f package | \
+ sed '
+ s/\$CARCH/i686/g
+ '
+)"
diff --git a/extra/ruby-sys-filesystem/PKGBUILD b/extra/ruby-sys-filesystem/PKGBUILD
new file mode 100644
index 00000000..f3b33334
--- /dev/null
+++ b/extra/ruby-sys-filesystem/PKGBUILD
@@ -0,0 +1,2 @@
+# https://github.com/djberg96/sys-filesystem/issues/71
+unset check
diff --git a/extra/samba/PKGBUILD b/extra/samba/PKGBUILD
index 131948ae..79f56e4d 100644
--- a/extra/samba/PKGBUILD
+++ b/extra/samba/PKGBUILD
@@ -1,20 +1,4 @@
-# disable CEPH support
-makedepends=(${makedepends[@]//ceph-libs/})
-
-eval "$(
- declare -f package_samba | \
- sed '
- /depends/ a \
- depends=(${depends[@]//ceph-libs/})
- '
-)"
-
-eval "$(
- declare -f build | \
- sed '
- s|./configure|./configure --disable-cephfs|
- '
-)"
+# -- Arch32 specific --
if test "$CARCH" == "i486"; then
eval "$(
@@ -24,3 +8,5 @@ if test "$CARCH" == "i486"; then
'
)"
fi
+
+eval "$(declare -f package_ldb | sed 's@x86_64@i386@')"
diff --git a/extra/texlive-bin/PKGBUILD b/extra/texlive-bin/PKGBUILD
new file mode 100644
index 00000000..111844f4
--- /dev/null
+++ b/extra/texlive-bin/PKGBUILD
@@ -0,0 +1 @@
+options+=(!debug !lto)
diff --git a/extra/tinysparql/PKGBUILD b/extra/tinysparql/PKGBUILD
new file mode 100644
index 00000000..a3ab997a
--- /dev/null
+++ b/extra/tinysparql/PKGBUILD
@@ -0,0 +1,7 @@
+# 33/41 tinysparql:sparql / sparql fails with out of memory
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(.*meson test.*\)/\1 || true/
+ '
+)"