Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/stochas/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/stochas/PKGBUILD')
-rw-r--r--extra/stochas/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/extra/stochas/PKGBUILD b/extra/stochas/PKGBUILD
new file mode 100644
index 00000000..734814d5
--- /dev/null
+++ b/extra/stochas/PKGBUILD
@@ -0,0 +1,12 @@
+# This requires SSE, so enable it on i686
+
+if [ "$CARCH" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ 3 i export CXXFLAGS="$CXXFLAGS -msse" CFLAGS="$CFLAGS -msse"
+ '
+ )"
+fi
+
+eval "$(declare -f package_stochas-vst3 | sed 's@\$CARCH@i386@g')"