Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/mesa/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mesa/PKGBUILD')
-rw-r--r--extra/mesa/PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index 0705c7b8..3f72c547 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -85,3 +85,19 @@ eval "$(
/find.*rmdir/d
'
)"
+
+# intel-rt is amd64 only
+eval "$(
+ declare -f build | \
+ sed '
+ s/-D intel-rt=enabled/-D intel-rt=disabled/
+ '
+)"
+
+# d3d12 causes linking errors
+eval "$(
+ declare -f build | \
+ sed '
+ s/,d3d12//
+ '
+)"