Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/boost
diff options
context:
space:
mode:
Diffstat (limited to 'extra/boost')
-rw-r--r--extra/boost/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/boost/PKGBUILD b/extra/boost/PKGBUILD
index 12fb68df..cf17845a 100644
--- a/extra/boost/PKGBUILD
+++ b/extra/boost/PKGBUILD
@@ -12,3 +12,12 @@ if [ "$CARCH" == 'i486' ]; then
'
)"
fi
+
+# disable complaining about stack trace feature which leaks memory
+eval "$(
+ declare -f build | \
+ sed '
+ s/cflags="\([^"]*\)"/cflags="\1 -DBOOST_STACKTRACE_LIBCXX_RUNTIME_MAY_CAUSE_MEMORY_LEAK"/g
+ s/cxxflags="\([^"]*\)"/cxxflags="\1 -DBOOST_STACKTRACE_LIBCXX_RUNTIME_MAY_CAUSE_MEMORY_LEAK"/g
+ '
+)"