Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/glib2/PKGBUILD6
-rw-r--r--core/gnutls/PKGBUILD2
-rw-r--r--core/linux/PKGBUILD11
-rw-r--r--core/pcre2/PKGBUILD2
4 files changed, 19 insertions, 2 deletions
diff --git a/core/glib2/PKGBUILD b/core/glib2/PKGBUILD
index 2d6cf671..03004ef9 100644
--- a/core/glib2/PKGBUILD
+++ b/core/glib2/PKGBUILD
@@ -6,3 +6,9 @@ declare -f check | \
s/\(meson test.*\)/\1 || true/
'
)"
+
+# Crappy hack to work around glib2-devel not being installed
+eval "$(
+ declare -f package_glib2 | \
+ sed '3i depends+=(glib2-devel)'
+)"
diff --git a/core/gnutls/PKGBUILD b/core/gnutls/PKGBUILD
index 3056d6a0..02b833fc 100644
--- a/core/gnutls/PKGBUILD
+++ b/core/gnutls/PKGBUILD
@@ -3,6 +3,6 @@
eval "$(
declare -f check | \
sed '
- s/make -j1 check/make -j1 check || true/
+ s/make check/make check || true/
'
)"
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 76b4daa6..e8cf0d85 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -25,10 +25,19 @@ eval "$(
a \
install -t "${builddir}/arch/x86" -m644 arch/x86/Makefile_32.cpu
}
- $ i depends+=(gcc-libs=$(_get_gcc_version_from_config))
'
)"
+# pin gcc-libs version (for pahole, kernel modules etc.)
+# currently not working because of 'creative' pkgver
+# versions upstream '14.1.1+r58+gfc9fb69ad62-1'
+#eval "$(
+# declare -f package_${pkgbase}-headers | \
+# sed '
+# $ i depends+=(gcc-libs=$(_get_gcc_version_from_config))
+# '
+#)"
+
_get_gcc_version_from_config() {
if [ -z "$srcdir" ]; then
gcc --version \
diff --git a/core/pcre2/PKGBUILD b/core/pcre2/PKGBUILD
index da90f860..fa4189bb 100644
--- a/core/pcre2/PKGBUILD
+++ b/core/pcre2/PKGBUILD
@@ -11,3 +11,5 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
fi
+
+unset check