Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/linux/PKGBUILD')
-rw-r--r--core/linux/PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 76b4daa6..e8cf0d85 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -25,10 +25,19 @@ eval "$(
a \
install -t "${builddir}/arch/x86" -m644 arch/x86/Makefile_32.cpu
}
- $ i depends+=(gcc-libs=$(_get_gcc_version_from_config))
'
)"
+# pin gcc-libs version (for pahole, kernel modules etc.)
+# currently not working because of 'creative' pkgver
+# versions upstream '14.1.1+r58+gfc9fb69ad62-1'
+#eval "$(
+# declare -f package_${pkgbase}-headers | \
+# sed '
+# $ i depends+=(gcc-libs=$(_get_gcc_version_from_config))
+# '
+#)"
+
_get_gcc_version_from_config() {
if [ -z "$srcdir" ]; then
gcc --version \