Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
Diffstat (limited to 'build-support')
-rw-r--r--build-support/nodoc-cli/PKGBUILD6
-rw-r--r--build-support/shellnocheck/PKGBUILD23
2 files changed, 26 insertions, 3 deletions
diff --git a/build-support/nodoc-cli/PKGBUILD b/build-support/nodoc-cli/PKGBUILD
index 9d91db44..d9d61aef 100644
--- a/build-support/nodoc-cli/PKGBUILD
+++ b/build-support/nodoc-cli/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
pkgname=nodoc-cli
-pkgver=1
+pkgver=4
pkgrel=1
pkgdesc="Conversion between documentation formats"
url="https://github.com/tatokis/nodoc"
diff --git a/build-support/shellnocheck/PKGBUILD b/build-support/shellnocheck/PKGBUILD
new file mode 100644
index 00000000..2efc21fb
--- /dev/null
+++ b/build-support/shellnocheck/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=shellnocheck
+pkgver=1
+pkgrel=1
+pkgdesc="Shell script analysis tool"
+url="https://github.com/tatokis/shellnocheck"
+license=("GPL-2.0-or-later")
+arch=('i486' 'i686' 'pentium4')
+provides=('shellcheck')
+conflicts=('shellcheck')
+replaces=('shellcheck')
+source=("git+https://github.com/tatokis/shellnocheck.git")
+sha256sums=('SKIP')
+makedepends=('git')
+
+build() {
+ cd shellnocheck
+ make
+}
+
+package() {
+ cd shellnocheck
+ install -D -m755 shellcheck -t "$pkgdir"/usr/bin/
+}