Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/protobuf/PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/extra/protobuf/PKGBUILD b/extra/protobuf/PKGBUILD
index 585863fe..aa67b1db 100644
--- a/extra/protobuf/PKGBUILD
+++ b/extra/protobuf/PKGBUILD
@@ -16,6 +16,10 @@ sha512sums+=("SKIP")
makedepends=(${makedepends[@]//bazel/})
eval "$(
- declare -f build | sed '/bazel build/d' | sed '$ d' | sed '$ a cd "../protobuf-5.${pkgver}"; python -m build --wheel --no-isolation ; }'
+ declare -f build | sed '/bazel build/d' | sed '$ d' | sed '$ a cd "$srcdir/protobuf-5.${pkgver}"; python -m build --wheel --no-isolation ; }'
declare -f package_python-protobuf | sed 's@ \".*bazel-bin/python@ \"protobuf-5.${pkgver}\"@'
)"
+
+if [[ $pkgver == "27.3" ]]; then
+ sha512sums[1]='18bc71031bbcbc3810a9985fa670465040f06a6c104ab8079b56bdfc499bb6cec40805a0cefd455031142490a576dc60aa8000523877ac0353b93558e9beabbd'
+fi