Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2024-09-02 11:59:01 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2024-09-02 11:59:01 +0200
commit98bff8608e93c0b82ac7bb198056f004bef276f3 (patch)
tree0c37ffa8d151d456e4bd2e0acb1d762d91eb6609 /extra
parentce790493127abbcf4d7cf6d6c58bc90885278457 (diff)
extra/ruby: no rust on i486
Diffstat (limited to 'extra')
-rw-r--r--extra/ruby/PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/extra/ruby/PKGBUILD b/extra/ruby/PKGBUILD
index b3d9a130..8408153f 100644
--- a/extra/ruby/PKGBUILD
+++ b/extra/ruby/PKGBUILD
@@ -36,3 +36,7 @@ if [[ $pkgver == 3.2.* ]]; then
# Suspect ^ is a container-related failure
eval "$(declare -f check | sed 's@make check@make check || true@')"
fi
+
+if [ "${CARCH}" = "i486" ]; then
+ makedepends=(${makedepends[@]//rust/})
+fi