Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/ruby
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-08-31 23:43:07 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-08-31 23:43:07 +0300
commit7370b21dac05bbc8c295d1d41a8cdc4267079107 (patch)
tree68ccea63f1756baa00a8bd5adb6b6f77ff4b40dd /extra/ruby
parent56abcf1acd1eef8e0db3d4179d62f1abc7c93b37 (diff)
extra/ruby: Fix prepare()
Diffstat (limited to 'extra/ruby')
-rw-r--r--extra/ruby/PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/extra/ruby/PKGBUILD b/extra/ruby/PKGBUILD
index c477d2f6..b3d9a130 100644
--- a/extra/ruby/PKGBUILD
+++ b/extra/ruby/PKGBUILD
@@ -19,12 +19,17 @@ if [ "${CARCH}" = "i486" ]; then
)"
fi
+prepare() {
+ cd "ruby-${pkgver}"
+ patch -p1 -i ../055613fd868a8c94e43893f8c58a00cdd2a81f6d.patch
+}
+
# Seems like 3.2.x will require this patch
if [[ $pkgver == 3.2.* ]]; then
source+=(055613fd868a8c94e43893f8c58a00cdd2a81f6d.patch)
unset sha512sums
b2sums+=(SKIP)
- eval "$(declare -f prepare | sed 's@patch @patch -p1 -i ../055613fd868a8c94e43893f8c58a00cdd2a81f6d.patch; patch @')"
+ #eval "$(declare -f prepare | sed 's@patch @patch -p1 -i ../055613fd868a8c94e43893f8c58a00cdd2a81f6d.patch; patch @')"
# MJIT might work on 3.3.x (might also need an explicit LDFLAGS="$LDFLAGS -fstack-protector" patch)
eval "$(declare -f build | sed 's@./configure@./configure --disable-jit-support@')"
# Global variable $0 actually sets the program name FAILED