Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/quazip/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-29 11:33:09 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-29 11:33:09 +0200
commit2145960c785a2e2081b323e30ee0ed27b5a77972 (patch)
tree1be8790ff4124eb1b537900a15f3eb9fe38dd7a3 /extra/quazip/PKGBUILD
parent06d0c1a6655160d7755bd71f3699388f951a83d5 (diff)
extra/quazip: fix for Qt5 builds (FS32#273)
Diffstat (limited to 'extra/quazip/PKGBUILD')
-rw-r--r--extra/quazip/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/quazip/PKGBUILD b/extra/quazip/PKGBUILD
new file mode 100644
index 00000000..a3ff50a4
--- /dev/null
+++ b/extra/quazip/PKGBUILD
@@ -0,0 +1,14 @@
+# build with non-probing CMakeLists.txt the qt5 version, assuming both
+# qt6 and qt5 artifacts are installed which make the automatic guesser
+# recognize the major version of Qt
+# (see also upstream FS#76054)
+source+=('CMakeLists-Qt5.txt')
+sha256sums+=('44378ad0642f14173b4d3b2f98332546d88ffe045db465c415d9c37708fdb1ea')
+eval "$(
+ declare -f build | \
+ sed '
+ /cmake -B build5/ i cp $pkgbase-$pkgver/CMakeLists.txt CMakeLists.bak \
+ cp CMakeLists-Qt5.txt $pkgbase-$pkgver/CMakeLists.txt
+ /cmake -B build6/ i cp CMakeLists.bak $pkgbase-$pkgver/CMakeLists.txt
+ '
+)"