Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/abseil-cpp
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2024-08-25 10:39:05 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2024-08-25 10:39:05 +0200
commit61d07f1ef20b19023e0f597575719cdaed88c983 (patch)
tree01cb8e6f0990eb2a65335de696e71917051711eb /extra/abseil-cpp
parent8db40a3aed9e19785ab23716514486287c52a11e (diff)
extra/abseil-cpp: fixed for -latomic and failing tests on i486
Diffstat (limited to 'extra/abseil-cpp')
-rw-r--r--extra/abseil-cpp/PKGBUILD17
1 files changed, 16 insertions, 1 deletions
diff --git a/extra/abseil-cpp/PKGBUILD b/extra/abseil-cpp/PKGBUILD
index b5c9ca6b..b81a17fb 100644
--- a/extra/abseil-cpp/PKGBUILD
+++ b/extra/abseil-cpp/PKGBUILD
@@ -1,3 +1,18 @@
# Tests are flaky
-
eval "$(declare -f check | sed 's/ctest/ctest || true/')"
+
+# Test cause OOM on u486
+if [ "$CARCH" = 'i486' ]; then
+ unset check
+ unset checkdepends
+fi
+
+# libatomic for i486
+if [ "$CARCH" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ 3 i export LDFLAGS=-latomic
+ '
+ )"
+fi