Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-build-boostrap/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 11:31:00 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 11:31:00 +0200
commit949b14981479c1c40f83d7d633af1f0f7fa6a17a (patch)
tree336b31c5f4f2d09b73c14c7a9879addeec67d1c7 /build-support/python-build-boostrap/PKGBUILD
parent8beb185e284d319393fe5a29e59b74f5321d2a05 (diff)
fixed completly wrong package name in python-build-bootstrap
Diffstat (limited to 'build-support/python-build-boostrap/PKGBUILD')
-rw-r--r--build-support/python-build-boostrap/PKGBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/build-support/python-build-boostrap/PKGBUILD b/build-support/python-build-boostrap/PKGBUILD
deleted file mode 100644
index 892ce420..00000000
--- a/build-support/python-build-boostrap/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
-# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
-
-_pkgname=build
-pkgname=python-$_pkgname
-pkgver=0.10.0
-pkgrel=4
-pkgdesc='A simple, correct PEP 517 build frontend'
-arch=('any')
-url='https://github.com/pypa/build'
-license=('MIT')
-makedepends=('git' 'python-pip-bootstrap')
-checkdepends=('python-pytest' 'python-pytest-mock' 'python-pytest-rerunfailures' 'python-filelock' 'python-setuptools' 'python-toml' 'python-wheel')
-source=("git+$url#tag=$pkgver?signed")
-validpgpkeys=('3DCE51D60930EBA47858BA4146F633CBB0EB4BF2') # Filipe Laíns (FFY00) <lains@archlinux.org>
-sha512sums=('SKIP')
-
-build() {
- cd $_pkgname
-
- # we install build, installer with pip to break the cycle
- pip install build
- pip install installer
- pip install flit_core
-
- python -m build --wheel --skip-dependency-check --no-isolation
-}
-
-package() {
- cd $_pkgname
-
- python -m installer --destdir="$pkgdir" dist/*.whl
-}