Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-07-13 10:14:42 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-07-13 10:14:42 +0300
commitd0fb8dac9629b97df9d6bdd10f8bbda084aaf8d2 (patch)
tree33968cebd8bc91268a67ba3e7e488fab5ecb4fbb
parentef5586bbc509db377629de06b6c146358cf36219 (diff)
extra/webkit2gtk: Redo patch and PKGBUILD
-rw-r--r--extra/webkit2gtk/PKGBUILD32
-rw-r--r--extra/webkit2gtk/i486.diff36
-rw-r--r--extra/webkit2gtk/i686.diff37
-rw-r--r--extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch50
4 files changed, 74 insertions, 81 deletions
diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
index 294674b3..ed606e4a 100644
--- a/extra/webkit2gtk/PKGBUILD
+++ b/extra/webkit2gtk/PKGBUILD
@@ -1,35 +1,5 @@
-# disable SSE2 on 486 and 686
-source_i486+=('webkitgtk-2.36.3-no-sse2.arch32.patch')
-source_i686+=('webkitgtk-2.36.3-no-sse2.arch32.patch')
-sha256sums_i486+=('58a724b7f1092a9049186a3b8c61689c31558b6c2b587c827cec04219397adac')
-sha256sums_i686+=('58a724b7f1092a9049186a3b8c61689c31558b6c2b587c827cec04219397adac')
-if [ "${CARCH}" != "pentium4" ]; then
- eval "$(
- declare -f prepare | \
- sed '
- /cd.*/a patch -Rp1 -i "$srcdir"/webkitgtk-2.36.3-no-sse2.arch32.patch
- '
- )"
-fi
-
-# do not build JIT code on non-pentium4 (breaks in micro-optimizations)
-eval "$(
- declare -f build | \
- sed '
- /cmake --build build/ ! {
- /^\s*cmake / {
- h
- s/^.*$/[ "${CARCH}" != pentium4 ] || \0/
- p
- g
- s/^\s*cmake /[ "${CARCH}" = pentium4 ] || \0-DENABLE_JIT=OFF -DENABLE_C_LOOP=ON -DENABLE_SAMPLING_PROFILER=OFF /
- }
- }
- '
-)"
-
-# Below from here
options+=('!debug' '!lto')
+
if [ "${CARCH}" != "pentium4" ]; then
eval "$(
declare -f prepare | \
diff --git a/extra/webkit2gtk/i486.diff b/extra/webkit2gtk/i486.diff
new file mode 100644
index 00000000..f794a6f5
--- /dev/null
+++ b/extra/webkit2gtk/i486.diff
@@ -0,0 +1,36 @@
+diff -ru webkitgtk-2.44.2/Source/ThirdParty/ANGLE/src/common/platform.h webkitgtk-2.44.2_sse/Source/ThirdParty/ANGLE/src/common/platform.h
+--- webkitgtk-2.44.2/Source/ThirdParty/ANGLE/src/common/platform.h 2024-03-16 06:45:47.852676000 +0000
++++ webkitgtk-2.44.2_sse/Source/ThirdParty/ANGLE/src/common/platform.h 2024-07-13 05:48:45.724474953 +0000
+@@ -112,7 +112,7 @@
+ #if defined(_MSC_VER) && !defined(_M_ARM) && !defined(_M_ARM64)
+ # include <intrin.h>
+ # define ANGLE_USE_SSE
+-#elif defined(__GNUC__) && (defined(__x86_64__) || defined(__i386__))
++#elif 0
+ # include <x86intrin.h>
+ # define ANGLE_USE_SSE
+ #endif
+diff -ru webkitgtk-2.44.2/Source/cmake/WebKitCompilerFlags.cmake webkitgtk-2.44.2_sse/Source/cmake/WebKitCompilerFlags.cmake
+--- webkitgtk-2.44.2/Source/cmake/WebKitCompilerFlags.cmake 2024-03-16 06:45:51.284670000 +0000
++++ webkitgtk-2.44.2_sse/Source/cmake/WebKitCompilerFlags.cmake 2024-07-13 05:50:15.429706698 +0000
+@@ -175,13 +175,13 @@
+ endif ()
+
+ # Force SSE2 fp on x86 builds.
+- if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
+- WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
+- include(DetectSSE2)
+- if (NOT SSE2_SUPPORT_FOUND)
+- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
+- endif ()
+- endif ()
++# if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
++# WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
++# include(DetectSSE2)
++# if (NOT SSE2_SUPPORT_FOUND)
++# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
++# endif ()
++# endif ()
+
+ # Makes builds faster. The GCC manual warns about the possibility that the assembler being
+ # used may not support input from a pipe, but in practice the toolchains we support all do.
diff --git a/extra/webkit2gtk/i686.diff b/extra/webkit2gtk/i686.diff
new file mode 100644
index 00000000..814b4e3b
--- /dev/null
+++ b/extra/webkit2gtk/i686.diff
@@ -0,0 +1,37 @@
+diff -ru webkitgtk-2.44.2/Source/ThirdParty/ANGLE/src/common/platform.h webkitgtk-2.44.2_sse/Source/ThirdParty/ANGLE/src/common/platform.h
+--- webkitgtk-2.44.2/Source/ThirdParty/ANGLE/src/common/platform.h 2024-03-16 06:45:47.852676000 +0000
++++ webkitgtk-2.44.2_sse/Source/ThirdParty/ANGLE/src/common/platform.h 2024-07-13 05:48:45.724474953 +0000
+@@ -112,7 +112,7 @@
+ #if defined(_MSC_VER) && !defined(_M_ARM) && !defined(_M_ARM64)
+ # include <intrin.h>
+ # define ANGLE_USE_SSE
+-#elif defined(__GNUC__) && (defined(__x86_64__) || defined(__i386__))
++#elif 0
+ # include <x86intrin.h>
+ # define ANGLE_USE_SSE
+ #endif
+diff -ru webkitgtk-2.44.2/Source/cmake/WebKitCompilerFlags.cmake webkitgtk-2.44.2_sse/Source/cmake/WebKitCompilerFlags.cmake
+--- webkitgtk-2.44.2/Source/cmake/WebKitCompilerFlags.cmake 2024-03-16 06:45:51.284670000 +0000
++++ webkitgtk-2.44.2_sse/Source/cmake/WebKitCompilerFlags.cmake 2024-07-13 05:47:42.679555436 +0000
+@@ -175,13 +175,14 @@
+ endif ()
+
+ # Force SSE2 fp on x86 builds.
+- if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
+- WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
+- include(DetectSSE2)
+- if (NOT SSE2_SUPPORT_FOUND)
+- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
+- endif ()
+- endif ()
++ WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse -mfpmath=387)
++# if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
++# WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
++# include(DetectSSE2)
++# if (NOT SSE2_SUPPORT_FOUND)
++# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
++# endif ()
++# endif ()
+
+ # Makes builds faster. The GCC manual warns about the possibility that the assembler being
+ # used may not support input from a pipe, but in practice the toolchains we support all do.
diff --git a/extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch b/extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch
deleted file mode 100644
index 63a098a7..00000000
--- a/extra/webkit2gtk/webkitgtk-2.36.3-no-sse2.arch32.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -rauN webkitgtk-2.36.3/Source/cmake/WebKitCompilerFlags.cmake webkitgtk-2.36.3-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake
---- webkitgtk-2.36.3/Source/cmake/WebKitCompilerFlags.cmake 2022-06-02 08:44:07.302049344 +0200
-+++ webkitgtk-2.36.3-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake 2022-06-02 08:32:46.169362098 +0200
-@@ -163,13 +163,13 @@
- endif ()
-
- # Force SSE2 fp on x86 builds.
--# if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
--# WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
--# include(DetectSSE2)
--# if (NOT SSE2_SUPPORT_FOUND)
--# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
--# endif ()
--# endif ()
-+ if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
-+ WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
-+ include(DetectSSE2)
-+ if (NOT SSE2_SUPPORT_FOUND)
-+ message(FATAL_ERROR "SSE2 support is required to compile WebKit")
-+ endif ()
-+ endif ()
-
- # Makes builds faster. The GCC manual warns about the possibility that the assembler being
- # used may not support input from a pipe, but in practice the toolchains we support all do.
-diff -rauN webkitgtk-2.36.3/Source/ThirdParty/ANGLE/src/common/platform.h webkitgtk-2.36.3-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/platform.h
---- webkitgtk-2.36.3/Source/ThirdParty/ANGLE/src/common/platform.h 2022-06-02 08:45:17.042348743 +0200
-+++ webkitgtk-2.36.3-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/platform.h 2022-06-02 08:32:46.189362180 +0200
-@@ -97,8 +97,8 @@
- # include <intrin.h>
- # define ANGLE_USE_SSE
- #elif defined(__GNUC__) && (defined(__x86_64__) || defined(__i386__))
--//# include <x86intrin.h>
--//# define ANGLE_USE_SSE
-+# include <x86intrin.h>
-+# define ANGLE_USE_SSE
- #endif
-
- // Mips and arm devices need to include stddef for size_t.
-diff -rauN webkitgtk-2.36.3/Source/WTF/wtf/PlatformCPU.h webkitgtk-2.36.3-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h
---- webkitgtk-2.36.3/Source/WTF/wtf/PlatformCPU.h 2022-06-02 08:46:55.912771827 +0200
-+++ webkitgtk-2.36.3-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h 2022-06-02 08:32:45.789360661 +0200
-@@ -99,7 +99,7 @@
- #define WTF_CPU_KNOWN 1
-
- #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
--/* #define WTF_CPU_X86_SSE2 1 */
-+#define WTF_CPU_X86_SSE2 1
- #endif
-
- #endif