Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-07-12 15:09:28 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-07-12 15:09:28 +0300
commit010c12a375ee06c9ce1aa49d5f356d8f68a07623 (patch)
treec8ccbe67e2e0233cf5ea60d6a4e82236011c6173
parent20d788d2bc694842d77b4ff0c9b10a30a969917f (diff)
build-support: Add shellcheck dummy replacement
-rw-r--r--build-support/shellnocheck/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/build-support/shellnocheck/PKGBUILD b/build-support/shellnocheck/PKGBUILD
new file mode 100644
index 00000000..2efc21fb
--- /dev/null
+++ b/build-support/shellnocheck/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=shellnocheck
+pkgver=1
+pkgrel=1
+pkgdesc="Shell script analysis tool"
+url="https://github.com/tatokis/shellnocheck"
+license=("GPL-2.0-or-later")
+arch=('i486' 'i686' 'pentium4')
+provides=('shellcheck')
+conflicts=('shellcheck')
+replaces=('shellcheck')
+source=("git+https://github.com/tatokis/shellnocheck.git")
+sha256sums=('SKIP')
+makedepends=('git')
+
+build() {
+ cd shellnocheck
+ make
+}
+
+package() {
+ cd shellnocheck
+ install -D -m755 shellcheck -t "$pkgdir"/usr/bin/
+}