Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Hvornum <anton.feeds+github@gmail.com>2020-07-08 12:34:22 +0000
committerAnton Hvornum <anton.feeds+github@gmail.com>2020-07-08 12:34:22 +0000
commit027f6695bf08f3febf6ad51cd916b24bdb3732d4 (patch)
treef9523f72ee1fb74788e58a92dd229e060a6bfc9f /setup.py
parentaecd333ea3020c0c575948763089cc829c36c56d (diff)
Adding symlink to examples.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 8 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8e7b2f96..ddd35cdf 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,13 @@
-import setuptools, glob
+import setuptools, glob, shutil
with open("README.md", "r") as fh:
long_description = fh.read()
+#shutil.copytree('examples', 'archinstall/examples')
+
setuptools.setup(
name="archinstall",
- version="2.0.2",
+ version="2.0.3rc5",
author="Anton Hvornum",
author_email="anton@hvornum.se",
description="Arch Linux installer - guided, templates etc.",
@@ -19,5 +21,7 @@ setuptools.setup(
"Operating System :: POSIX :: Linux",
],
python_requires='>=3.8',
- data_files=[('examples', glob.glob('examples/*.py'))],
-) \ No newline at end of file
+ package_data={'archinstall': glob.glob('examples/*.py')},
+)
+
+#shutil.rmtree('archinstall/examples') \ No newline at end of file