Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authoradvaithm <advaith.madhukar@gmail.com>2021-04-12 19:39:23 +0530
committeradvaithm <advaith.madhukar@gmail.com>2021-04-12 19:39:23 +0530
commit413565dbd0f4d5f5080f96c1d1ecd0c596e1d95b (patch)
tree8555fd78f3fc21021400ed66c380ba2e8b202da3 /pyproject.toml
parent7c902a6c83868abb7913a4303dfd36306ca8d189 (diff)
moved to flit build system
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml31
1 files changed, 29 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9787c3bd..330216df 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,30 @@
[build-system]
-requires = ["setuptools", "wheel"]
-build-backend = "setuptools.build_meta"
+requires = ["flit_core >=2,<4"]
+build-backend = "flit_core.buildapi"
+
+[tool.flit.metadata]
+module = "archinstall"
+author = "Anton Hvornum"
+author-email = "anton@hvornum.se"
+home-page = "https://archlinux.org"
+classifiers = [ "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
+"Programming Language :: Python :: 3.8",
+"Programming Language :: Python :: 3.9",
+"License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+"Operating System :: POSIX :: Linux",
+]
+description-file = "README.md"
+requires-python=">=3.8"
+[tool.flit.metadata.urls]
+Source = "https://github.com/archlinux/archinstall"
+Documentation = "https://archinstall.readthedocs.io/"
+
+[tool.flit.scripts]
+archinstall = "archinstall:run_as_a_module"
+
+[tool.flit.sdist]
+include = ["doc/"]
+exclude = ["doc/*.html"]
+
+[tool.flit.metadata.requires-extra]
+doc = ["sphinx"] \ No newline at end of file