index : archinstall32 | |
Archlinux32 installer | gitolite user |
summaryrefslogtreecommitdiff |
author | Andreas Baumann <mail@andreasbaumann.cc> | 2023-04-02 13:50:24 +0200 |
---|---|---|
committer | Andreas Baumann <mail@andreasbaumann.cc> | 2023-04-02 13:50:24 +0200 |
commit | af7ab9833c9f9944874f0162ae0975175ddc628d (patch) | |
tree | c486d4948b5994125f95c8aa1d61a059c1351127 /PKGBUILD | |
parent | 2caad35a885f9be30d5bf79a47f5456f276ae67b (diff) | |
parent | 6e3c6f8863041b54f6d8cf7af37f9719c493eadd (diff) |
-rw-r--r-- | PKGBUILD | 41 |
@@ -4,44 +4,63 @@ # Contributor: demostanis worlds <demostanis@protonmail.com> pkgname=archinstall -pkgver=2.5.0 -#pkgver=$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g') +pkgver=2.5.4 pkgrel=1 pkgdesc="Just another guided/automated Arch Linux installer with a twist" arch=(any) url="https://github.com/archlinux/archinstall" license=(GPL3) -depends=(python) -makedepends=(python-build python-installer python-flit python-setuptools python-sphinx python-wheel) -provides=(python-archinstall) -conflicts=(python-archinstall) -replaces=(python-archinstall) +depends=( + 'python' + 'systemd' +) +makedepends=( + 'python-setuptools' + 'python-sphinx' + 'python-build' + 'python-installer' + 'python-wheel' +) +optdepends=( + 'python-systemd: Adds journald logging' +) +provides=(python-archinstall archinstall) +conflicts=(python-archinstall archinstall-git) +replaces=(python-archinstall archinstall-git) source=( $pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz $pkgname-$pkgver.tar.gz.sig::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.sig ) -sha512sums=('9516719c4e4fe0423224a35b4846cf5c8daeb931cff6fed588957840edc5774e9c6fe18619d2356a6d76681ae3216ba19f5d0f0bd89c6301b4ff9b128d037d13' +sha512sums=('64cb3593c5091b3885ad14ef073cfab31090b4f9bcb4405b18cf9b19adb5ca42255ba8891ec62e21f92d59872541ef6d94f186fb05c625822af63525441e08d9' 'SKIP') -b2sums=('a29ae767756f74ce296d53e31bb8376cfa7db19a53b8c3997b2d8747a60842ba88e8b18c505bc56a36d685f73f7a6d9e53adff17953c8a4ebaabc67c6db8e583' +b2sums=('9c0ec0871841804377ba8310dc744711adcec4eed7319a8d89d684af8e7b822bb9d47540b00f4d746a9fcd7b9ea1b9e07bac773e6c28fabc760e4df38b16748b' 'SKIP') validpgpkeys=('256F73CEEFC6705C6BBAB20E5FBBB32941E3740A') # Anton Hvornum (Torxed) <anton@hvornum.se> +pkgver() { + cd $pkgname-$pkgver + + awk '$1 ~ /^__version__/ {gsub("\"", ""); print $3}' archinstall/__init__.py +} + prepare() { cd $pkgname-$pkgver + # use real directories for examples and profiles, as symlinks do not work - # with flit or setuptools PEP517 backends rm -fv $pkgname/{examples,profiles} mv -v examples profiles $pkgname/ } build() { cd $pkgname-$pkgver + python -m build --wheel --no-isolation PYTHONDONTWRITEBYTECODE=1 make man -C docs } package() { cd "$pkgname-$pkgver" + python -m installer --destdir="$pkgdir" dist/*.whl install -vDm 644 docs/_build/man/archinstall.1 -t "$pkgdir/usr/share/man/man1/" -}
\ No newline at end of file +} |