# This is an example of a PKGBUILD for splitting packages. Use this as a
# start to creating your own, and remove these comments. For more information,
# see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
# If it is unknown, then please put 'unknown'.

# Contributor: Your Name <youremail@domain.com>
pkgname=('pkg1' 'pkg2')
pkgbase=""
pkgver=VERSION
pkgrel=1
pkgdesc=""
arch=()
url=""
license=('GPL')
groups=()
depends=()
makedepends=()
provides=()
conflicts=()
replaces=()
backup=()
options=()
install=
source=($pkgbase-$pkgver.tar.gz)
noextract=()
md5sums=() #generate with 'makepkg -g'

build() {
  cd "$srcdir/$pkgbase-$pkgver"
  ./configure --prefix=/usr
  make || return 1
}

package_pkg1() {
  # options and directives that can be overridden
  pkgdesc=""
  license=()
  groups=()
  depends=()
  optdepends=()
  provides=()
  conflicts=()
  replaces=()
  backup=()
  options=()
  install=

  cd "$srcdir/$pkgbase-$pkgver"
  make DESTDIR="$pkgdir/" install-pkg1
}

package_pkg2() {
  # options and directives overrides
  pkgdesc=""

  cd "$srcdir/$pkgbase-$pkgver"
  make DESTDIR="$pkgdir/" install-pkg2
}