# disable documentation (needs sphinx, sphinx-rtd_theme, npm)
# python-sphinx_rdt_theme needs npm, which is broken on archlinux32
# most likely since years..
makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
makedepends=(${makedepends[@]//python-sphinx/})
eval "$(
 declare -f build | \
    sed '
      /local meson_options.*/ a \
        meson_options+=(-D doc=disabled)
    '
 declare -f package_wireplumber | \
    sed '
      /_pick.*docs.*/d
    '
 declare -f package_wireplumber-docs | \
    sed '
      /mv.*docs.*/d
    '
)"

# for now disable testing on i486, doesn't work at all but we want
# to satisfy dependencies and hope nobody uses it :)
if [ "$CARCH" == 'i486' ]; then
  unset check
  unset checkdepends
fi