# set _JARCH to IA32
_JARCH=x86

# make sure -no-plt is set also for pentium4 and i486 (otherwise
# we get GOT linking errors)
eval "$(
  declare -f build | \
    sed '
       /CARCH/s/i686/${CARCH}/
    '
)"

# pentium4-specific
if [ "${CARCH}" = "pentium4" ]; then
  # force 4-byte stack alignment on SSE aptimized systems, see FS32#75
  eval "$(
    declare -f build | \
      sed '
        /unset CFLAGS/ i \
          _CFLAGS="${_CFLAGS} -mincoming-stack-boundary=2" \
          _CXXFLAGS="${_CXXFLAGS} -mincoming-stack-boundary=2"
      '
  )"

fi

# fix location of images in case they are wrong
_imgdir="${_imgdir//--/-${_JARCH}-}"

# pandoc is mainly broken currently (FS32#180)
makedepends=(${makedepends[@]//pandoc/})

# for some reason we cannot install java-environment=10 if it comes
# from build-support only
# also, we want to use the lowest version of java explicitely being
# able to build Java 11 (which is 10)
makedepends=(${makedepends[@]//java-environment>=10/})
makedepends=(${makedepends[@]//java-environment<12/})
makedepends+=(jdk10-openjdk)