# FAIL: clang-tidy/abseil-duration-factory-scale.cpp
# see https://bugs.llvm.org/show_bug.cgi?id=41460
# => for now run checks, but make failure non-fatal..
eval "$(
  declare -f check | \
    sed '
      s/\(ninja.*\)/\1 || true/
    '
)"

# clang tests in clang-tidy hang build slaves due to
# races in the python tests, disabled them all for now
# as we cannot disable them individually..
if [ "$CARCH" = 'i486' ]; then
  unset check
fi