# download location broken (FS#75636)
source[0]="https://dlcdn.apache.org/apr/apr-$pkgver.tar.bz2"
source[1]="https://dlcdn.apache.org/apr/apr-$pkgver.tar.bz2.asc"

# uint64_t probing broken, see
# https://github.com/apache/apr/pull/25
# https://github.com/apache/apr/commit/0a763c5e500f4304b7c534fae0fad430d64982e8?diff=unified
source+=('apr-1.7.0-no-explicit-confdefs-uint64-probing.patch')
sha256sums+=('bac28c5519081e3854a11e97ff4493719a98c140b17d9980f8ea8380cbb9bfa3')
eval "$(
  {
    declare -f prepare || \
    printf 'prepare() { cd "${pkgname}-${pkgver}"\n}\n'
  } \
  | sed '
    /buildconf/ i patch -Rp1 -i "../apr-1.7.0-no-explicit-confdefs-uint64-probing.patch"
  '
)"

# i486-specific, missing atomics
if [ "${CARCH}" = "i486" ]; then
  eval "$(
    declare -f build | \
      sed '
        s|./configure |LDFLAGS="-latomic" ./configure |g
      ';
  )"
fi

if [ "${CARCH}" = "i486" ]; then
  eval "$(
    declare -f build | \
      sed '
        s/--enable-nonportable-atomics/--disable-nonportable-atomics/
      '
    )"
fi