# include sysmacros.h in extlinux, otherwise you get undefined references
# to minor and major

source+=(syslinux-sysmacros.patch)
sha1sums+=('52c5233da147acd41d542b1673835be966b561e3')

eval "$(
  declare -f prepare | \
    sed '
      /patch.*efi_no_kbd/a patch -p1 < ../syslinux-sysmacros.patch
    '
)"

# binutils adds a nore.gnu.proprerty ELF section, this makes the MBR slightly
# too big to fit on disk (see also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906414)

source+=(syslinux-strip-gnu-property.patch)
sha1sums+=('fb8e96b559516038e628ad55e0331e4c668205a8')

eval "$(
  declare -f prepare | \
    sed '
      /patch.*efi_no_kbd/a patch -p1 < ../syslinux-strip-gnu-property.patch
    '
)"

# don't build efi64
_targets='bios efi32'