# 486-specific: we have no Vala or Java at the moment
if [ "${CARCH}" = "i486" ]; then
  # pcre2 configure, overload CFLAGS and CXXFLAGS to avoid optimization
  # using MMX registers (default in gcc)
  # disable JIT, contains hard coded XMM registers
  eval "$(
    declare -f build | \
      sed '
        s@./configure@CFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" CXXFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" ./configure@
        s/--enable-jit/--disable-jit/
      '
  )"
fi