# It seems, compiling for i686 is as simple as specifying you want i686.

eval "$(
  declare -f build check | \
    sed '
      s|x86-64|i686|
      s|make |make default_pic=true|
    '
)"

# the compiler seems fine, but the test frameworks seems to break with
# newer LLVM, for now, ignoring the tests:
# https://github.com/ponylang/ponyc/issues/2875
unset check