Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/extra-cmake-modules/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-07-05 12:50:46 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-07-05 12:50:46 +0200
commit81ea46923a51240ed9ef350ada6cbd88124ebb2d (patch)
tree035a1f3402fff0914740f4ce1914fa0000b05f6e /extra/extra-cmake-modules/PKGBUILD
parentfe1931a16e36d1f544c04f0229758ddba1884462 (diff)
extra/extra-cmake-modules: made linker warnings non-fatal
Diffstat (limited to 'extra/extra-cmake-modules/PKGBUILD')
-rw-r--r--extra/extra-cmake-modules/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/extra-cmake-modules/PKGBUILD b/extra/extra-cmake-modules/PKGBUILD
new file mode 100644
index 00000000..fa60d6a2
--- /dev/null
+++ b/extra/extra-cmake-modules/PKGBUILD
@@ -0,0 +1,14 @@
+# workaround for i686 which generates warning about GNU_PROPERTY(5): size 0
+source+=('extra-cmake-modules-5.59.0-ld-no-fatal-warning.patch')
+sha256sums+=('045ec564ffacfffcc6ea1f6b7dc74860d0c51a8f85e93beec7e27d1fdbe97de7')
+
+# 686-specific
+if [ "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /.*patch.*/ a \
+ patch -Np1 -i ../extra-cmake-modules-5.59.0-ld-no-fatal-warning.patch
+ '
+ )"
+fi